Results 1 to 10 of 10

Thread: HELP! Rough Idle at stop light, already cleaned EGR and IAC, replaced mounts

  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    1
    Feedback Score
    0

    HELP! Rough Idle at stop light, already cleaned EGR and IAC, replaced mounts

    Help, I'm at my wit's end with my 97 LX protege 1.5L.

    It's that common rough idle problem with the protege.

    Right now, my car idles very rough, interior vibrates like crazy when I pull to
    a stop sign or stop light, with the brakes pressed, and in drive. The RPM
    surges up and down to close to 1-1.5k? It gets a bit worse with A/C and
    defogger on. If I switch to neutral, vibration goes away.

    I have cleaned out EGR, cleaned out throttle body, replaced PCV, changed air
    filter, replaced breather tube, changed fuel filter, replaced timing belt,
    ac/power steering belt, water pump, mounts, spark plugs.

    Yes the mechanic has run me to the ground replacing belts, and mounts, fuel
    filter I cleaned the EGR, and throttle body myself. I also cleaned the IAC
    valve too.

    Most recently, the mechanic said that the TB gasket was on backwards - a bunch
    of BS....so he put it back on and put sealant all around it.

    Since then, the car still idles rough almost a bit worse. I bought a used MAF,
    which actually increased the acceleration/power response for the car a bit. I
    also replaced the battery, and cleaned up terminals and ground connections.
    However, the idling is still poor.

    Recently, the check engine light came on, then went away. The code was P0505.
    I have since bought a used throttle body with IAC valve. I already tried
    cleaning the exisitng one, but could the IAC just be bad? Should I replace it
    with a used one? Are there any other sensors that could be bad?

    The car was meticulously serviced and has 98000 miles on it. I'm at the point
    where I may want to get rid of it if I can not solve this idling problem.

    Do you have any other suggestions? Or anybody in SF Bay area want to buy a 97
    Protege - with rough idle - lol! It has new front brakes, and relatively new
    tires! Already replaced timing belt and water pump! It just vibrates at stop
    signs that's all!


    Thanks for your help

    Phil

  2. #2
    Registered User
    Join Date
    Aug 2003
    Location
    Corona, CA
    Posts
    2,323
    Feedback Score
    2 (100%)
    wow, so quick to sell it with such a small problem...lol

    have you checked the TPS sensor?


  3. #3
    Marauderator turbonium959's Avatar
    Join Date
    Aug 2003
    Location
    Norwood, MA
    Posts
    984
    Feedback Score
    0
    I assume that you read my post on the other forum, and glad to see that you are here. But I am not sure if you took into consideration the info I provided:

    CODE P0505
    DETECTION CONDITION

    - PCM detects no continuity of idle air control valve curcuit
    - Actual engine speed is excesseively higher or lower than target speed preset in PCM for more than 14 sec.

    POSSIBLE CAUSE

    - Idle air control valve malfunction
    - Leakage in intake-air system
    - Open or short circuit in wiring from idle air control valve terminal A to PCM terminal 4G
    - Open or short circuit in wiring from idle air control valve terminal B to PCM terminal 4H

    So, it seems to me that IAC valve could be the culprit, so try to replace it with the used one, and if that does not fix, try to replace it with a new one.
    "Probable impossibilities are to be preferred to improbable possibilities."

  4. #4
    Registered User
    Join Date
    Aug 2004
    Location
    Anywhere i want to be
    Posts
    1,168
    Feedback Score
    0
    its most likely your cylinder miss fires at idle.......mine does the same thing and does get worse when i have my AC/heater on also gets worse when i turn on/off my headlights, mine only does it in Drive, Reverse. in Nuetral and in Park it just makes my RPM jump around but my car doesint shake as bad
    Last edited by Mazda96Protege; 12-28-2004 at 08:08 PM.

  5. #5
    irobot
    Join Date
    Nov 2003
    Location
    California, USA
    Posts
    4,286
    Feedback Score
    1 (100%)
    Hey, I live in the SF Bay Area and I have the same problem! It must be the high concentration of silicon in the air (we live in the Silicon Valley after all). lol j/k

    I have the same problem, but mine is related to low compression in all cylinders but number 1.

    Have you done a compression test?

  6. #6
    Registered User skullone's Avatar
    Join Date
    Nov 2003
    Location
    Portland, OR
    Posts
    44
    Feedback Score
    0
    I'd be real interested to see if either of you fixed the idle problems.
    My car is starting to develope idle problems as well.
    Stopped, dips to 150-200 rpm, bounces to 750, dips, and so on.
    I've replaced:
    Air filter, PCV valve, fuel filter, cleaned EGR, new plugs, cap, distributor, wires.
    Just about all the first poster, except motor mounts.

    It really bugs the hell out of me. I dont have any misfire codes, but who knows. It still could be, its real sluggish when you accelerate (more so than a normal z5)

    Besides replacing the engine, I dont know what to do next!
    Damn z5

  7. #7
    Registered User
    Join Date
    Jan 2005
    Posts
    39
    Feedback Score
    0
    my idle has got so bad that the cd player skips(not a crapy on a pioner), and the passenger window shakes its self down an inch or so, i also have 170k miles so its an old '97, does any one know the flat out cure

  8. #8
    Registered User
    Join Date
    Jan 2005
    Posts
    2
    Feedback Score
    0

    New plug wires solved my rough idle

    At stoplights my idle kept getting worse and worse until eventually my car would die at a redlight. Plug wires solved the problem.

  9. #9
    Registered User ALDawg727's Avatar
    Join Date
    Jun 2004
    Posts
    1
    Feedback Score
    0

    bad idle prob

    i had the same problem with my 97 pro lx, and i got the chiltons repair guide. and just by chance i was flipping through the guide and stopped on a page that had am idle air adjustment instructions. and it said that there was a screw on top of the intake manifold that you can turn to adjust this problem, and i adjusted it and my car no longer shakes me to death whenevr i turn anything electrical on or pull up to a stop light. i will try and take a pic of the screw and post it later

  10. #10
    Registered User
    Join Date
    Oct 2003
    Location
    Miami, Florida & Put your loca
    Posts
    1,727
    Feedback Score
    0
    This problem seems to have plagued Proteges since the first generation in 1990. Here is a link where the topic was discussed at length. If you really solved your problem with the "shakes" the it probaby wasn't the same problem the rest of us are having because even the dealerships could not cure the problem on my 1994 Protege DX. By the way, you never posted that picture. Here's the link to the frustrating story. It's a few pages long:

    http://www.protegeclub.com/forum/sho...ight=bad+vibes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97-1.8 Protege rough idle when coming to a full stop
    By Han in forum Engine/Drivetrain - BHA Chassis
    Replies: 8
    Last Post: 07-07-2011, 12:55 PM
  2. Help! EGR Removal on a 2000 and IAC Question
    By pcantin in forum Engine/Drivetrain - BJ Chassis
    Replies: 3
    Last Post: 07-05-2011, 10:26 PM
  3. 98 LX P0505, IAC, rough idle, loss of power, #4 fouled, wtf
    By Pro in forum General Discussion - BHA Chassis
    Replies: 16
    Last Post: 11-13-2007, 12:00 PM
  4. IAC (idle air control) valve
    By elmerfudd in forum Engine/Drivetrain - BHA Chassis
    Replies: 7
    Last Post: 10-17-2007, 10:59 AM
  5. really high idle after IAC replacement
    By RonBurgundy in forum Engine/Drivetrain - BG Chassis
    Replies: 17
    Last Post: 04-17-2007, 12:57 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •