Results 1 to 3 of 3

Thread: KL47 MAP sensor problems.

  1. #1
    Registered User
    Join Date
    Dec 2016
    Location
    Indianapolis
    Posts
    3
    Feedback Score
    0

    KL47 MAP sensor problems.

    I'm working on a 2000 Protegé, 1.6 DX, the MAP sensor showed inconsistent voltage so I thought I'd start, as I always do, by locating the part and checking my vacuum lines. Trouble is, the vacuum line off the bottom of the KL47 sensor is cut off.

    Looking at my Mitchell diagrams, the KL47 should be routed to a solenoid valve (BP4Y-18-741). I cannot locate that solenoid, it's wiring harness, or and open vacuum port on the car, neither can I locate a comprehensive vacuum diagram which shows where and how the vacuum is supplied to both the valve and MAP sensor.

    I've called four dealerships, no luck.

    Whatever you've got will help.
    Last edited by Loquetur; 12-02-2016 at 11:33 AM. Reason: Additional information.

  2. #2
    Registered User
    Join Date
    Dec 2016
    Location
    Indianapolis
    Posts
    3
    Feedback Score
    0
    Eureka!

    After consulting a few diagrams from Mazda, I found that the KL47 MAP sensor on manual cars has a single vacuum hose coming out the bottom, the call-out number for which is 18-292. It's a short piece of hose with a 45° cut on one end and it connects to absolutely nothing.

    The MAP sensor literally only reads the ambient barometric pressure of the surrounding environment, and does I don't know what with that information.

    I'm going to go clean the EGR now.

  3. #3
    suspension mods intheworks FE3-323's Avatar
    Join Date
    Aug 2003
    Location
    Madison, Wisconsin
    Posts
    23,968
    Feedback Score
    79 (100%)
    sounds like an early MAF/MAP combo. which is cool that they integrated something like that. equals out to better readings.
    regardless- glad you got something figured out here tho
    ---Has ClubProtege helped you in someway? show your support by Contributing--- Click Here---

    1992- project FE3..... 313 WHP @ 9.3psi




    I pet my dash when I get into the car..."good car"
    he actually has a mazda tree, parts grow on it


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MAP Sensor
    By Laporteryan in forum Engine/Drivetrain - BJ Chassis
    Replies: 15
    Last Post: 12-04-2014, 08:03 AM
  2. Map sensor
    By BG ALL DAY in forum Engine Management & Proper Tuning
    Replies: 3
    Last Post: 03-17-2010, 10:32 AM
  3. how much $$ is a map sensor ....
    By jraz305 in forum Engine/Drivetrain - BG Chassis
    Replies: 6
    Last Post: 11-25-2007, 12:08 AM
  4. map sensor
    By fordegt in forum Forced Induction/Nitrous
    Replies: 4
    Last Post: 01-09-2007, 09:37 PM
  5. map sensor
    By fordegt in forum Forced Induction/Nitrous
    Replies: 0
    Last Post: 01-07-2007, 11:38 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •